Page 1 of 1

Directadmin บน FreeBSD หลักจากอัพเกรด start apache ไม่ได้

Posted: 01/11/2017 11:27 am
by mindphp
เจอ Erro
/usr/local/etc/rc.d/httpd start
Starting httpd: [ OK ]
httpd: Syntax error on line 18 of /etc/httpd/conf/httpd.conf: Syntax error on line 1 of /etc/httpd/conf/extra/httpd-phpmodules.conf: Cannot load /usr/lib/apache/libphp5.so into server: /usr/local/lib/libiconv.so.3: unsupported file layout

จาก แจ้งปัญหา Syntax error
ไม่สามารถโหลดไฟล์ /usr/lib/apache/libphp5.so

Re: Directadmin บน FreeBSD หลักจากอัพเกรด start apache ไม่ได้

Posted: 01/11/2017 1:20 pm
by mindphp
ปัญหาหลักมาจาก
/libexec/ld-elf.so.1: /usr/local/lib/libiconv.so.3: unsupported file layout

Re: Directadmin บน FreeBSD หลักจากอัพเกรด start apache ไม่ได้

Posted: 01/11/2017 3:46 pm
by mindphp
ปัญหา มาจาก built php เวอร์ชั่น ที่ lib ไม่ตรงกับของในเครื่อง
แก้ปัญหาโดย built php ใหม่เป็นเวอร์ชั่น ที่ stable

ด้วยคำสั่ง

Code: Select all

cd /usr/local/directadmin/custombuild
./build set php5_ver 5.3
./build update
./build php n
./build rewrite_confs