ให้เรตสมาชิก: 1 / 5

ดาวใช้งานดาวไม่ได้ใช้งานดาวไม่ได้ใช้งานดาวไม่ได้ใช้งานดาวไม่ได้ใช้งาน
 

ติดตั้ง Odoo 9 แล้วเจอ Error

odoo : Depends: python-ofxparse but it is not installable
        Recommends: antiword but it is not going to be installed
        Recommends: ghostscript
        Recommends: postgresql but it is not going to be installed
        Recommends: python-gevent but it is not going to be installed
        Recommends: poppler-utils
ปัญหามาจาก ไฟล์ ติดตั้งของ deb เวอร์ชั่นนี้มีปัญหากับ lib บางตัวของ python

ทางแก้ คือ เราติดตั้ง module เสริมของ Python เอง โดยแล้วค่อยไปติดตั้ง Odoo ผ่าน .deb ใหม่

แก้ปัญหาได้ตาม ขั้นตอนนี้

wget http://archive.ubuntu.com/ubuntu/pool/universe/p/python-ofxparse/python-ofxparse_0.14.orig.tar.gz
sudo tar zxvf python-ofxparse_0.14.orig.tar.gz
cd ofxparse-0.14/
python setup.py install

เสร็จแล้วกลับไปติดตั้ง Odoo ใหม่อีกครั้งด้วย คำสั่ง

 apt-get update && apt-get -f install odoo --fix-missing

เท่านี้เราก็จะได้ ERP ใช้งานด้วย Odoo แล้ว

ERP ไม่ได้อยากที่การติดตั้ง แต่ การใช้งาน ประยุกต์ให้เข้ากับ ธุรกิจ ของเรายังไง ยากกว่า ต้องอาศัยคนมีประสบการณ์ในการ Implement หรือเป็นที่ปรึกษาให้

 

ถ้ายังมีปัญหา คำสั่งนี้ช่วยท่านได้

apt-get -f install  python-bs4
กระทู้ล่าสุดจากเว็บบอร์ด
หัวข้อกระทู้
ตอบ
เปิดดู
ล่าสุด
.js พิมพ์ 5K -> แปลงค่าเป็น 5,000.00 พิมพ์ 1.5M แปลงค่าเป็น 1,500,000.00
โดย jataz2 อ 17 พ.ย. 2020 4:10 pm บอร์ด JavaScript & Jquery Ajax
0
76
อ 17 พ.ย. 2020 4:10 pm โดย jataz2
การเดินทางจาก ฉะเชิงเทรา ไป กทม.
โดย haritoat จ 16 พ.ย. 2020 3:31 pm บอร์ด พูดคุยเรื่องทั่วไป จับฉ่าย
1
96
จ 16 พ.ย. 2020 6:07 pm โดย thatsawan
ออมเงินด้วย สลากออมสิน
โดย jataz2 จ 16 พ.ย. 2020 2:54 pm บอร์ด พูดคุยเรื่องทั่วไป จับฉ่าย
0
70
จ 16 พ.ย. 2020 2:54 pm โดย jataz2
อัพเกรด Directadmin แล้วเจอ Error e2fsprogs-devel-1.41.12-3.el6.x86_64 has missing requires of e2fsprogs-libs
โดย mindphp อ 15 พ.ย. 2020 1:36 pm บอร์ด ถาม - ตอบ คอมพิวเตอร์
1
60
อ 15 พ.ย. 2020 1:38 pm โดย mindphp
ขอสอบถาวิธีแก้ปัญหา ทำไมเพิ่มข้อมูลคำพจนานุกรมไป , ใน ฐานข้อมูล , ดูเหมือนหมวดหมู่จะ Insert ไม่เข้าครับ
โดย makup ศ 13 พ.ย. 2020 11:30 am บอร์ด ปัญหาการใช้ phpBB3, SMF, Joomla, Wordpress, CMS, CRM
2
97
อ 15 พ.ย. 2020 4:25 am โดย บุคคลทั่วไป
รับติดตั้งระบบ Microsoft Skype for Business and Microsoft Teams
โดย Atomseed Suckseed ศ 13 พ.ย. 2020 11:23 am บอร์ด พูดคุยเรื่องทั่วไป จับฉ่าย
0
52
ศ 13 พ.ย. 2020 11:23 am โดย Atomseed Suckseed
แก้ปัญหา ติดตั้ง PHP 7.4 ไม่ได้ บน Server เจอ Error error: Package requirements (icu-uc >= 50.1 icu-io icu-i18n) were no
โดย mindphp ศ 13 พ.ย. 2020 12:36 am บอร์ด ถาม - ตอบ คอมพิวเตอร์
2
69
ศ 13 พ.ย. 2020 1:38 am โดย mindphp
คำสั่ง บน Linux สำหรับ เช็คว่า port ไหน มีการใช้งานแล้ว และใช้กับอะไร
โดย bolue พฤ 12 พ.ย. 2020 4:54 pm บอร์ด Linux - Web Server
1
73
ศ 13 พ.ย. 2020 9:31 pm โดย cresencio123