ผมรัน flask แล้ว Error pillow ครับ

Post a reply

Smilies
:icon_plusone: :like: :plusone: :gfb: :-D :) :( :-o 8O :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen: :angry: :baa: :biggrin:
View more smilies

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: ผมรัน flask แล้ว Error pillow ครับ

Re: Error

by teenproza7 » 30/05/2019 8:10 pm

วิธีแก้ทำการ ลบ pillow เดิมออกโดยทำการ เปิด Terminal

แล้ว พิมพ์

Code: Select all

sudo python -m pip uninstall Pillow 
ดังภาพ
removepillow2.png
removepillow2.png (12.21 KiB) Viewed 606 times
จากนั้นโปรแกรมจะแสดงดังรูป
removepillow3.png
removepillow3.png (74.65 KiB) Viewed 606 times
จากนั้นกด y แล้ว enter

หลังจากนั้นทำการติดตั้ง pillow v.4.0.0 ใหม่ โดย ใช้คำสั่ง

Code: Select all

 sudo python -m pip install Pillow==4.0.0 


รอโปรแกรมติดตั้งจนเสร็จ

Re: Error

by mindphp » 30/05/2019 8:04 pm

หนักการในการตั้งคำถาม
viewtopic.php?f=132&t=41240

ผมรัน flask แล้ว Error pillow ครับ

by teenproza7 » 30/05/2019 8:02 pm

ผมทำการรัน Flask แต่เกิด Error ดังนี้ครับ
/home/com003/PycharmProjects/mdsoft_generate_rml_to_pdf_miniproject/venv/bin/python /home/com003/PycharmProjects/mdsoft_generate_rml_to_pdf_miniproject/index.py
Traceback (most recent call last):
File "/home/com003/PycharmProjects/mdsoft_generate_rml_to_pdf_miniproject/index.py", line 8, in <module>
from z3c.rml import rml2pdf
File "/home/com003/PycharmProjects/mdsoft_generate_rml_to_pdf_miniproject/venv/local/lib/python2.7/site-packages/z3c/rml/__init__.py", line 6, in <module>
__version__ = pkg_resources.require('z3c.rml')[0].version
File "/home/com003/PycharmProjects/mdsoft_generate_rml_to_pdf_miniproject/venv/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 900, in require
needed = self.resolve(parse_requirements(requirements))
File "/home/com003/PycharmProjects/mdsoft_generate_rml_to_pdf_miniproject/venv/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 791, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (Pillow 3.4.2 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pillow>=4.0.0'), set(['reportlab']))

Process finished with exit code 1

Top