สอบถาม การติดตั้ง library ด้วย requirements.txt

แนะนำ สอบถาม ภาษา C สำหรับผู้เริ่มต้น ภาษา Java ภาษา Python

Moderator: mindphp, ผู้ดูแลกระดาน

ภาพประจำตัวสมาชิก
jirawoot
PHP Super Hero Member
PHP Super Hero Member
โพสต์: 557
ลงทะเบียนเมื่อ: 17/06/2019 10:30 am

สอบถาม การติดตั้ง library ด้วย requirements.txt

โพสต์โดย jirawoot » 15/07/2019 2:57 pm

สอบถาม การติดตั้ง library ด้วย requirements.txt ถูกต้องไม่ไหมครับผมเห็นมี error ถ้าไม่ถูกต้องขอคำแนะนำด้วยครับ

server ubuntu ครับ
ไฟล์ requirements.txt

โค้ด: เลือกทั้งหมด

passlib==1.7.1
Flask_Login==0.4.1
Flask==1.0.3
Flask_HTTPAuth==3.3.0
psycopg2_binary==2.8.3
configparser==3.7.4


โค้ด: เลือกทั้งหมด

root@ubuntu-2gb-sgp1-01:/htmltoPdfImage2# pip install -r requirements.txt
Downloading/unpacking passlib==1.7.1 (from -r requirements.txt (line 1))
Downloading passlib-1.7.1-py2.py3-none-any.whl (498kB): 498kB downloaded
Downloading/unpacking Flask-Login==0.4.1 (from -r requirements.txt (line 2))
Downloading Flask-Login-0.4.1.tar.gz
Running setup.py (path:/tmp/pip_build_root/Flask-Login/setup.py) egg_info for package Flask-Login

Downloading/unpacking Flask==1.0.3 (from -r requirements.txt (line 3))
Downloading Flask-1.0.3-py2.py3-none-any.whl (92kB): 92kB downloaded
Requirement already satisfied (use --upgrade to upgrade): Flask-HTTPAuth==3.3.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 4))
Downloading/unpacking psycopg2-binary==2.8.3 (from -r requirements.txt (line 5))
Downloading psycopg2-binary-2.8.3.tar.gz (378kB): 378kB downloaded
Running setup.py (path:/tmp/pip_build_root/psycopg2-binary/setup.py) egg_info for package psycopg2-binary
/usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'project_urls'
warnings.warn(msg)
/usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'python_requires'
warnings.warn(msg)

Error: You need to install postgresql-server-dev-X.Y for building a server-side extension or libpq-dev for building a client-side application.

Complete output from command python setup.py egg_info:
/usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'project_urls'

warnings.warn(msg)

/usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'python_requires'

warnings.warn(msg)

running egg_info

creating pip-egg-info/psycopg2_binary.egg-info

writing pip-egg-info/psycopg2_binary.egg-info/PKG-INFO

writing top-level names to pip-egg-info/psycopg2_binary.egg-info/top_level.txt

writing dependency_links to pip-egg-info/psycopg2_binary.egg-info/dependency_links.txt

writing manifest file 'pip-egg-info/psycopg2_binary.egg-info/SOURCES.txt'

warning: manifest_maker: standard file '-c' not found

Error: You need to install postgresql-server-dev-X.Y for building a server-side extension or libpq-dev for building a client-side application.



----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in /tmp/pip_build_root/psycopg2-binary
Storing debug log for failure in /root/.pip/pip.log
root@ubuntu-2gb-sgp1-01:/htmltoPdfImage2#

error

โค้ด: เลือกทั้งหมด

Error: You need to install postgresql-server-dev-X.Y for building a server-side extension or libpq-dev for building a client-side application.

ภาพประจำตัวสมาชิก
mindphp
ผู้ดูแลระบบ MindPHP
ผู้ดูแลระบบ MindPHP
โพสต์: 21090
ลงทะเบียนเมื่อ: 22/09/2008 6:18 pm
ติดต่อ:

Re: สอบถาม การติดตั้ง library ด้วย requirements.txt

โพสต์โดย mindphp » 15/07/2019 4:05 pm

ตัวแจ้ง error บอกว่า ต้องมี postgresql-server ด้วย เวอร์ชั่น แล้วแต่เราจะกำหนด
เป็นเพราะ บางโมดูลที่เรา ทำไฟล์ requirements.txt ไปเรียกใช้โมดูลหรือโปรแกรมนั้นไว้
ติดตาม VDO: http://www.youtube.com/c/MindphpVideoman
ติดตาม FB: https://www.facebook.com/pages/MindphpC ... 9517401606
หมวดแชร์ความรู้: viewforum.php?f=29
รับอบรม และพัฒนาระบบ: viewtopic.php?f=6&t=2042

ภาพประจำตัวสมาชิก
jirawoot
PHP Super Hero Member
PHP Super Hero Member
โพสต์: 557
ลงทะเบียนเมื่อ: 17/06/2019 10:30 am

Re: สอบถาม การติดตั้ง library ด้วย requirements.txt

โพสต์โดย jirawoot » 15/07/2019 4:12 pm

mindphp เขียน:ตัวแจ้ง error บอกว่า ต้องมี postgresql-server ด้วย เวอร์ชั่น แล้วแต่เราจะกำหนด
เป็นเพราะ บางโมดูลที่เรา ทำไฟล์ requirements.txt ไปเรียกใช้โมดูลหรือโปรแกรมนั้นไว้

ก็คือต้องตัว postgresql-server อยู่ในไฟล์ requirements.txt ด้วยใช่ไหมครับ

ภาพประจำตัวสมาชิก
jirawoot
PHP Super Hero Member
PHP Super Hero Member
โพสต์: 557
ลงทะเบียนเมื่อ: 17/06/2019 10:30 am

Re: สอบถาม การติดตั้ง library ด้วย requirements.txt

โพสต์โดย jirawoot » 15/07/2019 4:39 pm

วิธีแก้
viewtopic.php?p=148714#p148714


  • Similar Topics
    ตอบกลับ
    แสดง
    โพสต์ล่าสุด

ย้อนกลับไปยัง

ผู้ใช้งานขณะนี้

กำลังดูบอร์ดนี้: 13 และ บุคคลทั่วไป 0 ท่าน