Page 1 of 1

ปัญหาเข้า localhost/phpmyadmin ไม่ได้

Posted: 31/05/2016 12:29 pm
by worachat
ขั้นที่ 1 start xampp ได้แล้วครับ แต่มันบอกว่าเกิดปัญหาอยู่
13.png
13.png (32.33 KiB) Viewed 5598 times

Code: Select all

12:18:20  [Apache] 	Problem detected!
12:18:20  [Apache] 	Port 80 in use by ""C:\AppServ\Apache24\bin\httpd.exe" -k runservice" with PID 1472!
12:18:20  [Apache] 	Apache WILL NOT start without the configured ports free!
12:18:20  [Apache] 	You need to uninstall/disable/reconfigure the blocking application
12:18:20  [Apache] 	or reconfigure Apache and the Control Panel to listen on a different port
ขั้นที่ 2 พอมาดูใน netstet มันบอกว่า socket มีตัวใหม่และตัวเก่าอยู่
14.png
14.png (32.49 KiB) Viewed 5598 times
ขั้นที่ 3 พอมาเข้า localhost/phpmyadmind มันขึ้นแบบนี้อ่ะครับ
12.png
12.png (18.97 KiB) Viewed 5598 times
ผมควรจะทำอย่างไรดีครับ

Re: ปัญหาเข้า localhost/phpmyadmin ไม่ได้

Posted: 31/05/2016 1:46 pm
by worachat
ลองลบ AppServ ที่เคยโหลดมาแล้วครับ ยังไม่ได้ครับ

Re: ปัญหาเข้า localhost/phpmyadmin ไม่ได้

Posted: 31/05/2016 1:55 pm
by thatsawan

Re: ปัญหาเข้า localhost/phpmyadmin ไม่ได้

Posted: 01/06/2016 5:35 pm
by worachat

Code: Select all

12:18:20  [Apache]    Problem detected!
12:18:20  [Apache]    Port 80 in use by ""C:\AppServ\Apache24\bin\httpd.exe" -k runservice" with PID 1472!
12:18:20  [Apache]    Apache WILL NOT start without the configured ports free!
12:18:20  [Apache]    You need to uninstall/disable/reconfigure the blocking application
12:18:20  [Apache]    or reconfigure Apache and the Control Panel to listen on a different port
ถ้ามองถึงปัญหาที่เกิดขึ้นแล้ว ทาง xampp จะมีการบอกว่าจุด ที่ error เกิดจากสาเหตุอะไร สาเหตุเกิดจาก ผมเคยโหลด App serv ไว้ จึงทำให้ xampp เกิดปัญหาครับ

วิธีแก้นะครับ
1. ให้ลบ ตัว App serv ทั้งหมด พร้อมกับการถอดการติดตั้งออก
2. Restart เครื่องใหม่
3. หาก xampp ยัง Start ไม่ได้ ให้ถอนการติดตั้ง xampp ลงใหม่อีกครั้ง
4. Restart เครื่องใหม่

ถ้าไม่มีโปรแกรมอื่นมารบกวน xampp ก็คงจะรันได้แล้วละครับ สู้ๆ