สอบถามปัญหาติดตั้ง extension บน phpBB 3.3.3 แล้วขึ้น error

พูดคุย phpBB3, SMF ปัญหา การติดตั้ง ปัญหา การลง Mod การแก้ไข หน้าตาบอร์ด การใช้งาน Joomla 1.5, 1.6, 1.7, 2.5 ,3.x และเร็วๆนี้ Joomla จะออกเวอร์ชั่น 4.0 การใช้งาน wordpress และ CMS อื่นๆ
การตั้งคำถาม ควรระบุรุ่นที่ใช้ ในการตั้งคำตามด้วย นะ เช่น SMF 1.1.4 หรือ SMF2.0 Joomla 1.0 joomla 3.8 และ รายละเอียดของ server OS , php เวอร์ชั่นไหน ฐานข้อมูลอะไร

Moderator: mindphp

Forum rules
คำถามหมวดนี้ ควรระบุ รายละเอียดของ Server OS, เวอร์ชั่น ของ PHP, CMS ที่ท่านใช้
รวมถึง Hosting หรือ Control Panel Hosting
User avatar
eange08
PHP Super Hero Member
PHP Super Hero Member
Posts: 874
Joined: 22/12/2020 10:09 am

สอบถามปัญหาติดตั้ง extension บน phpBB 3.3.3 แล้วขึ้น error

Post by eange08 »

ติดตั้ง extension แล้วมันขึ้นเตือนแบบนี้ ปกติหรือเปล่าค่ะ ต้องแก้ไขอย่างไรค่ะ
(ใช้ phpBB 3.3.3)
screenshot-localhost-2021.02.11-11_00_52.png
ข้อความในกรอบสีแด

Code: Select all

phpBB encountered an error building the container due to an installed extension. For this reason, all extensions have been temporarily disabled. Please try purging your forum cache. All extensions will automatically be re-enabled once the container error is resolved. If this error continues, please visit phpBB.com for support.


Exception: The file "/opt/lampp/htdocs/helpdesk2/ext/mindphp/m_cross/config/services.yml" does not contain valid YAML: The reserved indicator "@" cannot start a plain scalar; you need to quote the scalar at line 7 (near "- @auth").

#0 /opt/lampp/htdocs/helpdesk2/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php(117): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->loadFile('/opt/lampp/htdo...')
#1 /opt/lampp/htdocs/helpdesk2/phpbb/extension/di/extension_base.php(99): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->load('services.yml')
#2 /opt/lampp/htdocs/helpdesk2/phpbb/extension/di/extension_base.php(63): phpbb\extension\di\extension_base->load_services(Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#3 /opt/lampp/htdocs/helpdesk2/vendor/symfony/dependency-injection/Compiler/MergeExtensionConfigurationPass.php(71): phpbb\extension\di\extension_base->load(Array, Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#4 /opt/lampp/htdocs/helpdesk2/vendor/symfony/http-kernel/DependencyInjection/MergeExtensionConfigurationPass.php(39): Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#5 /opt/lampp/htdocs/helpdesk2/vendor/symfony/dependency-injection/Compiler/Compiler.php(140): Symfony\Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#6 /opt/lampp/htdocs/helpdesk2/vendor/symfony/dependency-injection/ContainerBuilder.php(789): Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#7 /opt/lampp/htdocs/helpdesk2/phpbb/di/container_builder.php(223): Symfony\Component\DependencyInjection\ContainerBuilder->compile()
#8 /opt/lampp/htdocs/helpdesk2/common.php(115): phpbb\di\container_builder->get_container()
#9 /opt/lampp/htdocs/helpdesk2/adm/index.php(23): require('/opt/lampp/htdo...')
#10 {main}
User avatar
thatsawan
PHP VIP Members
PHP VIP Members
Posts: 28524
Joined: 31/03/2014 10:02 am
Contact:

Re: สอบถามปัญหาติดตั้ง extension บน phpBB 3.3.3 แล้วขึ้น error

Post by thatsawan »

รูปแบบการเขียนไฟล์ YML จะต้องปรับใหม่ตาม phpbb 3.3
ปัญหาการใช้ phpBB3, SMF, Joomla, Wordpress, CMS, CRM-1.png
ปัญหาการใช้ phpBB3, SMF, Joomla, Wordpress, CMS, CRM-1.png (10.01 KiB) Viewed 477 times
User avatar
eange08
PHP Super Hero Member
PHP Super Hero Member
Posts: 874
Joined: 22/12/2020 10:09 am

Re: สอบถามปัญหาติดตั้ง extension บน phpBB 3.3.3 แล้วขึ้น error

Post by eange08 »

อันนี้ต้องแก้ในไฟล์ service.yml ใช่ไหมค่ะ
แต่ในนี้มันเรียกที่ event ต้องเปลี่ยนเป็น controller ไหม
ปัญหาการใช้ phpBB3, SMF, Joomla, Wordpress, CMS, CRM-1.png
ปัญหาการใช้ phpBB3, SMF, Joomla, Wordpress, CMS, CRM-1.png (31.45 KiB) Viewed 475 times
User avatar
thatsawan
PHP VIP Members
PHP VIP Members
Posts: 28524
Joined: 31/03/2014 10:02 am
Contact:

Re: สอบถามปัญหาติดตั้ง extension บน phpBB 3.3.3 แล้วขึ้น error

Post by thatsawan »

แก้ไข ส่วน argumants ให้ " ครอป ไม่เกี่ยว event หรือ controller
User avatar
eange08
PHP Super Hero Member
PHP Super Hero Member
Posts: 874
Joined: 22/12/2020 10:09 am

Re: สอบถามปัญหาติดตั้ง extension บน phpBB 3.3.3 แล้วขึ้น error

Post by eange08 »

แก้ให้ครอบด้วย " ด้วยหมดแล้วแต่พอกด refresh ก็ขึ้น error

Code: Select all

arguments:
            - "@auth"
            - "@cache"
            - "@config"
            - "@dbal.conn"
            - "@request"
            - "@template"
            - "@user"
            - "@controller.helper"
            - "%core.root_path%"
            - "%core.php_ext%"
            - "%core.table_prefix%"
            - "%tables.m_cross_client%"
Error ที่แสดงออกมา

Code: Select all

Fatal error: Uncaught ArgumentCountError: Too few arguments to function mindphp\m_cross_site_client\event\listener::__construct(), 0 passed in /opt/lampp/htdocs/helpdesk1/cache/production/container_4335734bbdd20f586549a504dff5f80c.php on line 2201 and exactly 12 expected in /opt/lampp/htdocs/helpdesk1/ext/mindphp/m_cross_site_client/event/listener.php:26 Stack trace: #0 /opt/lampp/htdocs/helpdesk1/cache/production/container_4335734bbdd20f586549a504dff5f80c.php(2201): mindphp\m_cross_site_client\event\listener->__construct() #1 /opt/lampp/htdocs/helpdesk1/vendor/symfony/event-dispatcher/EventDispatcher.php(231): phpbb_cache_container->{closure}() #2 /opt/lampp/htdocs/helpdesk1/vendor/symfony/event-dispatcher/EventDispatcher.php(61): Symfony\Component\EventDispatcher\EventDispatcher->sortListeners('core.user_setup') #3 /opt/lampp/htdocs/helpdesk1/vendor/symfony/event-dispatcher/EventDispatcher.php(43): Symfony\Component\EventDispatcher\EventDispatcher->getListeners('core.user_setup') #4 /opt/lampp/htdocs/helpdesk1/phpbb/eve in /opt/lampp/htdocs/helpdesk1/ext/mindphp/m_cross_site_client/event/listener.php on line 26
User avatar
eange08
PHP Super Hero Member
PHP Super Hero Member
Posts: 874
Joined: 22/12/2020 10:09 am

Re: สอบถามปัญหาติดตั้ง extension บน phpBB 3.3.3 แล้วขึ้น error

Post by eange08 »

thatsawan wrote: 11/02/2021 3:57 pm ลบเเคช ก่อน
ติดตั้งได้แล้วค่ะ ขอบคุณค่ะ
Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ปัญหาการใช้ phpBB3, SMF, Joomla, Wordpress, CMS, CRM”

Who is online

Users browsing this forum: Bing [Bot] and 7 guests